Adding RTL8111B/RTL8111C network driver to Solaris Jumpstart

My jumpstart client has a builtin RTL8111B/RTL8111C network card. When i boot up the client thru PXE booting it gives me an error "no driver was found for the interface used to boot jumpstart"

Download the updated SUNWrge package, this holds the driver for rge

http://www.aplis.cz/SUNWrge.tar.gz

My Jumpstart image is shared thru NFS in /installer directory
#cd /installer/boot

Create a temporary miniroot directory
#mkdir x86.miniroot-rge.unpacked

Unpack the existing miniroot to the temp miniroot directory
#/boot/solaris/bin/root_archive unpack ./x86.miniroot ./x86.miniroot-rge.unpacked


Remove the existing SUNWrge package
#pkgrm SUNWrge

Add the updated SUNWrge package
#cd /export/home/john
#gunzip SUNWrge.tar.gz
#tar xvf SUNWrge.tar
#pkgadd -d . SUNWrge

Check the new aliases
#grep rge /etc/name_to_major /etc/driver_aliases
/etc/driver_aliases:rge "pci10ec,8169"
/etc/driver_aliases:rge "pci10ec,8110"
/etc/driver_aliases:rge "pci10ec,8168"
/etc/driver_aliases:rge "pci10ec,8111"


Remove the existing rge driver in the jumpstart miniroot
#cd /installer/boot
#/usr/sbin/rem_drv -b ./x86.miniroot-rge.unpacked/ rge

Add the new driver
#/usr/sbin/add_drv -b ./x86.miniroot-rge.unpacked  -n -v -m '* 0600 root sys' -i '"pci10ec,8169" "pci10ec,8110" "pci10ec,8168" "pci10ec,8111"' rge

Reboot client to install driver.
Driver (rge) installed.

Backup original miniroot
#mv x86.miniroot x86.miniroot.orig

Compress the new Jumpstart miniroot
#/boot/solaris/bin/root_archive pack ./x86.miniroot ./x86.miniroot-rge.unpacked/



Sources:
Jeff's Solaris Admin blog

General Solaris 10 discussion

By penoi on Friday, August 8, 2008 | | 4 comments
4 responses to “Adding RTL8111B/RTL8111C network driver to Solaris Jumpstart”
  1. [...] - Adding RTL8111B/RTL8111C network driver to Solaris Jumpstart saved by ipod908762008-09-19 - Show full process name / path / string in Solaris using ps saved by [...]

  2. Mark Walmsley says:

    if you have a problem with only icmp traffic working here is the fix

    add

    set ip:dohwcksum = 0

    to /etc/system

  3. Joseph says:

    Jeff,
    When I run the rem_drv or for that matter, the add_drv as well, i am getting this:

    root@solaris:/export/install/media/sol-10-u7-ga-x86/boot# rem_drv -b ./unpacked/ rge
    add_drv/rem_drv currently busy; try later

    Any ideas?
    Thanks!

  4. Gugi says:

    The file SUNWrge.tar.gz is not found on the url you gave above.

    i'd like to get it...

    where i can find it...?